Dashingdon - 404 Error


#1

Okay, hi everyone.

I looked through the forum, but couldn’t find an answer to this error;

I am trying to upload my game on Dashingdon for the case that Dropbox should really disable html support, but whatever I do, I don’t seem to get to fix this problem.
What have I done so far? I tried to upload a compiled game into DashingDon as well as a few simple scenes. Nothing so far except the error above.

I found out that there’s the option to get the link to the game to work without problem, but clicking on the banner itself on the site does cause a problem as above stated.

Does anyone have an idea on how DashingDon works?

EDIT: DashingDon seems to hate me… I just got it to work somehow ._.
Anyway, thanks for reading, I guess…

This is embarrassing._.


Chronic 404 at certain scenes
#2

Hello! No, you’re not taking crazy pills, this was entirely my fault.

In the last update I had made it so that if a compiled HTML file was not on the server, the compiled options in ‘Edit Game Details’ would not display. Unfortunately, due to a very nerdy oversight, I prevented ALL games from being given the compiled options. :sweat: Whoops.

Sorry about the trouble! Fixed now. :grin:

P.S. I just clicked the game link to double-check and now I’m stuck reading this amazing game again. :fearful: I won’t be able to quit until I reach the end again now. So there goes the next hour or so! Aww crackers! :stuck_out_tongue_closed_eyes:


#3

Haha, no problem! XD

It works now just peachy for a few minutes, so the link and banner works just fine now :3
Thank you for fixing that!

EDIT: Ehehe <3
I am currently trying to look if I can find mistakes in my current process of the game and if I linked every scene, then I might upload the new scenes as well.
Then you might have some new stuff to read x)


#4

A coop project I tried uploading earlier today (the bookshop game) gives a 404 error too, but I was just using .txt files, so that can’t be this issue. So… Help? :no_mouth:


#5

This appears to be the same issue I had to fix this morning with colons and other characters (apostrophe in this case) in the game title. I have tested the account and game directory now and files are uploading correctly. Apologies for the trouble! :sweat_smile:


#6

The help is much appreciated. :thumbsup:


#7

Patient:

Symptoms:
During the lunch scenes near the end of the demo, people keep getting an error 404 when they choose certain options, but not other ones. It happened to me too, but only when I played it on Dashingdon, not when I played it using the files I have on my computer, which makes me think it has something to do with Dashingdon. Tried re-uploading all the affected scenes, but that doesn’t appear to have changed anything.


#8

The only relevant txt file I am seeing is 1-9lunch-1Lucyfriend-1safe.txt

The others @ParrotWatcher mentioned are not in the /scenes/ folder. There are equivalent ‘Lucy’ text files but not ‘Lucyfriend’ text files, as seen here:

https://dashingdon.com/play/interestedparty/through-broken-lenses/mygame/scenes/

Looks like those files didn’t upload for some reason or another maybe? Could you try again? If they don’t upload, let me know and I’ll look into it posthaste. Thanks.


#9

Slightly off-topic, @dashingdon, but would it be possible to put a link to the “scenes” page in the “upload files” page, just so it’s easy to see which files have been uploaded?


#10

Yes that’s a good idea. I’ll implement when I have some time later today.


#11

Right, so, I’m seeing a problem here that I didn’t notice earlier. When I select the files and press the big friendly upload button, the green bar does it’s green bar thing but the text reads “0 files uploaded”

Can’t remember if it did that the first time, but I tried it a couple more times after I realized this so I’m going to assume it did


#12

I’m getting a 404 error - any help?


#13

When I got it, it turned out that game files hadn’t transferred to Dashingdon


#14

DashingDon’s sometimes logs you out without telling you, and so you can still apparently be on the upload page, but it won’t actually let you upload anything. In that case, you might have to move back to the main page, and log in again.


#15

I believe we have worked out the issues Eiwynn was having. The server is case-sensitive in all things, and requires file extensions, so sometimes things that work locally will not work on the DashingDon server.


#16

Hey there
I’m having similar problems. Keep getting that 404 error while trying to privately playtest my game.
Any ideas?


#17

@Arjavos I don’t see any scene files for your game. Are you having issues uploading them? I see there are a lot of asset files, including images and sound files, but no text files.