[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

Would there be a way to export it to dashingdon?

If you export your CSIDE project to HTML, no? I’m not sure since I use the online version of choicescript :thinking: :man_shrugging:

1 Like

I fixed it!

1 Like

Has anyone managed to get CSIDE to run on Linux recently? The package available on Github is so old, it refuses to run even after updating all Grunt dependencies.

I haven’t tried it for a long, long while. There’s simply no (mass) market for it here on the forums. Even Mac doesn’t seem to see much use. Users are predominantly Windows.

If you want to PM me info on your issues, I’ll try to help, but can’t afford to spend the time supporting it officially.

The issues are predominantly from certain dependencies being outdated and unsupported anymore. I decided to just move to the web version and not bother rebuilding the entire thing since I only have myself to blame for abandoning Windows.

1 Like

You can also try my electron branch, which is much newer: GitHub - ChoicescriptIDE/main at electron

Though you’d basically be building a nightly build at that point. No quality guarantee at all!

1 Like

I just finished setting up a local dropbox instance on my PC to sync the project between the web client and my GDrive so I’ll stick to it for now, but maybe next time I migrate to a different OS I’ll give it a shot.

1 Like

okay, not fixed but how do you turn the whole thing into a html on web?

A strange error popped up on a new project in CSIDE. … I SOLVED this, but wanted to share anyhow in case this catches anyone else out! It was sorta subtle but easy to solve when the real issue was revealed.

PROBLEM:
CSIDE error "Couldn’t load scene ‘01_lobby’ The file doesn’t exist
Screenshot 2024-02-12 090449

Even though I have the file listed correctly as 01_lobby in the startup.txt file in the project file and I have that 01_lobby.txt file right in there as well, which can be opened and edited happily within CSIDE, the IDE really doesn’t like this file for some reason and posts the error even when bringing the correct targeted file into the code browser…

SOLUTION:
It turns out that I have used a capital L for the scene file in Explorer but it showed up in the CSIDE browser as what looked to me like lowercase. So the error really was correctly warning me – the targeted file had one different letter than I recognized.

Peering at my copy of CSIDE I just… couldn’t tell the difference! I didn’t find it until I opened my project folder in CMD and output a tree map… boy was I embarrassed!

Hope this helps anyone like me who drum up scene files quickly and throw them into sequence when testing ideas. Don’t mix cases!

1 Like

Now that I’ve given something back, I do have one more persistent confusion that I could use help with from the crew here who use CSIDE so aggressively: where to put image files?

The latest project I’m creating in a github repo with just the scenes files and image files. I want to use *image or *text-image occasionally for chapter headings and similar. But despite trying a number of locations for the image file, I couldn’t get images to appear in any way. Images haven’t been a priority for me, so I’ve always sorta ignored this.

I’m using CSIDE 1.3.3

Here is my folder structure – it is for a fun project I’ll share about next week when it is done, my first non-fiction-driven (mostly) CS project. The title will give you a hint - it is an interview in choicescript form to accompany a zine article featuring an IF author in this community!

-–Truth Under Stars
±–images
-–scenes
01_lobby.txt
02_auditorium.txt
03_snackbar.txt
04_merchtable.txt
05_coatcheck.txt
choicescript_stats.txt
startup.txt

I have a few images I’d like to use, and I’m wondering if I can put them in the /images folder perhaps via some …/images/file.png trickery? or where do YOU put them, and in what version of CSIDE?

These are all .png and .jpg files

I’ve tried so far:

  • in the scenes folder
  • the folder one level up from /scenes
  • the /images folder in the folder one level up from /scenes
  • a new /images folder inside scenes called via *text_image images/01_lobby.png center The Lobby

Also, it hasn’t been working for images to post in any of the sources I have inspected as well to drop images into the /scenes folder – it used to over a year ago, but not since. I’m not that focused on images for this work, so I just figured I was missing something obvious.

If anyone can help me solve this, I’ll be particularly grateful, and I’ll give you a shout out in the project. (There is actually a natural place where to do so.)

CSIDE doesn’t have a concept of a scene folder, only a project folder, where all files should go. So your images should go next to your scenes. That said, if you wanted to have an images folder under there, that should work as well (as long as you’re specifying , images/myimg.jpg).

1 Like

Any hints why CSIDE 1.3.3 for windows might NOT render any photos, just the little placemarker for not loading the image?

I have the image I want, prologue.png, and I placed it in the same folder with all of the scene files.
I called it in my first scene file after my startup.txt: 01_lobby.txt as:

*image prologue.png center The Lobby

and I also tried *text_image

But I always just get the broken image link look like this:
image

Any hints for things I haven’t tried that I should try?

Thanks for the headsup that I don’t need to maintain the /mygame/scenes/ folder concept and just have a master folder for my CSIDE projects with all files inside.

It’s a bug, I’ll try and get a fix out this week.

2 Likes

Thanks so much! I’ll wait patiently! Thank you for all your effort with this really handy tool!

Hello everyone

after an automatic update from my laptop, I cant seem to open any of my scenes on my IDE choicescript program. After all the scene’s there is a red arrow and it wont open the scene. I desperately hope that I can still access these files, as I have not saved them in a while on another place.

Anyone who knows what I can do?

afbeelding

thanks
Emma

Since the latest update, every time I upload a compiled game to itch.io, the very first choice gets the error: “Permission denied to access property “cside” on cross-origin object”

The only way I’ve been able to fix this is by reverting to an older version. (Which I don’t mind in general, except then I have to make sure not to use *selectable_if together with *fake_choice or it’ll throw errors at that instead when played.) Does anyone know if there’s a fix in the works for this? I’ve googled for ways to fix the bug, but all of the proposed solutions are much harder to use than just going back to the earlier CSIDE version.

This is most likely because the files have been moved. If you hover over the warning :warning: icon it’ll describe the problem.

I’m aware of this issue and hope to provide a fix in the near future.