[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

I think this is a tech issue and not an user issue @CJW might need to take over from here.

1 Like

Just create a new project (new name) and copy the old files over manually (through your file explorer).
Close the old and new project in CSIDE, then go into the device (explorer) again and rename the folder to the original project name. Now open the scene files in the new folder - should be back to normal.

1 Like

I’ll try that. Thanks.

It works, but my work is no longer saved to my flashdrive.

Even still, It’s a big improvement. 'preciate it.

1 Like

Glad to hear it. If you really want to work directly off a flash drive (I don’t recommend it), you’ll need to assign it a static drive letter. See: https://www.howtogeek.com/96298/assign-a-static-drive-letter-to-a-usb-drive-in-windows-7/

1 Like

I was trying to use CSIDE to compile a game but I keep getting this error when I open the compiled file:

Any ideas what I could be doing wrong? It’s odd because startup is listed in the scene list, but there is a file called startup and it plays ok via the index so it shouldn’t be missing?
(I was using the background colour mod here, could that have upset CSIDE? If likely, does anyone know how to compile files with mods/images?)

Edit: Never mind, I think it’s the mod. If I compile images with CSIDE and then bring them back into the choicescript compiler it seems to work well :slight_smile:

1 Like

CSIDE has an internal copy of ChoiceScript that you can’t modify, so it won’t work with any mods I’m afraid.


For the record, EXDEV errors are usually raised when you try to rename files across different devices. If windows (or linux) thinks your file is on one device and you try to rename it onto a different device, you’ll get this error. The message you were getting suggested you were trying to rename a file from F: to C: and that’s not possible. You have to copy or move files across devices, not rename them.


Alright, I’m in a very tough pickle.

I am currently using ChoiceScript IDE. I’ve been working on a certain chapter for quite a few weeks, and it was a toughie to code. I had approximately 11k words which I had worked very hard on, and I might have lost them–I need to know if I can get them back.

I was writing, and I needed to check the stats for a certain part. So, I click the play-test button, and it says “file may have been moved or deleted”. So, like the idiot I am, instead of usually just closing and re-opening the program like I usually do when I have an issue of this nature (it would have probably fixed it), I think, “Oh! Let me just open the .txt files I have saved from the game.” I do just that, and only after I open them, effectively overriding my present progress, do I remember that I have not converted the 11k words I have just written to a .txt file yet. I only do so when I am ready to upload the chapter on my forum post.

So, now, my 11k words are presumably gone. I had saved the actual txt file within the program multiple times (clicking the little “save” icon next to the chapter name), but I’m not sure if opening a text file with the same name has overwritten it. I am sincerely hoping my progress is SOMEWHERE within CSIDE.

Thank you so much for your time.

1 Like

Sorry, might be rather unhelpful. Look in the documents panel and in Choicescript Projects. Might be there. If not, I am sorry.

Choicescript auto-saves quite often, so you may not have lost as much as you think you have. Have you reopened the game in Choice Script IDE?

1 Like

I’m assuming this is the desktop version of CSIDE, as opposed to the web version? Either way, CSIDE doesn’t store your data, it writes it back to the text file like any other editor. Opening the same file twice won’t be allowed, so that’s unlikely to have caused any problems. You’ll probably find your file is still there under /user/name/ChoiceScript Projects/Project Name/file.txt

Edit: I’ll take this opportunity to say (again), whatever software you’re using, however much you write/wherever you save - always back up your work! Things can and do go wrong, it’s not worth not backing up.

1 Like

No, I’ve saved the game tons. The issue is, previously I had the scene with around 50 words, thanking the readers and giving updates on progress. That is the scene I had in my WIP game that is currently uploaded in the game right now.

I accidentally opened that .txt file that’s in the WIP and potentially overwrote the 11k words with the 50 words in the original txt file.

Get what I mean?

Thanks for your time!

I haven’t saved my writing in an exported .txt file, if that’s what you’re saying. I explained it a bit better (apologies for the confusion in my original post) replying to another user—but basically, the original scene had 50 words. I wrote 11k words, and accidentally opened the 50-word-txt file.

Will it still be lost?

Thank you so much!

Which version of CSIDE are you using?

The latest, I believe. How do you check?

Asking more whether it’s in your web browser (https://choicescriptide.github.io/web) or a downloaded desktop copy.

I’m afraid I don’t entirely understand what your problem is. You can’t overwrite one file by opening another, that isn’t how text editors (in general) work. Unless you’ve directly modified the 11k word file yourself, or neglected to save it (seems unlikely, as autosave should be on by default), then the file should still be around somewhere.


I’ve found it! Took your advice. Under documents->choicescript projects, thank goodness; it wasn’t in the different files I saved them in.

Thank you so so much for everything. Back on track, now!


I don’t know what’s causing it but if i install CSIDE anywhere except in appdata/local it gives an error while downloading updates ( tried installing in program files and program files (x86))

Specifically this error CSIDE%20BUG

while it updates just fine when i install it in the default folder

This is the reason it’s installed to appdata. Writing files to the program files directory is usually restricted, which is why your update is failing. You can either use the default recommendation or change the permissions on the directory within program files.