[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

Yes, we’re going to need a little more information than that. Are you using the browser version of CSIDE or the desktop version? If it’s the latter, what operating system are you using? If it’s the former, what web browser?

Specific error messages or screenshots are very helpful.

Hello, I downloaded the app days ago but for some reason whenever I try to update it, I get an error message (both from the stable and latest channel)

here’s the screenshot
SS

I’ve sent you a PM.

Hi! I get the same Error message. What do I do now?

I’ve added you to the PM.

v1.3.3 Release Now Available (Latest, Development, Web)

Patch release. Upgrades ChoiceScript providing support for the new ‘create_array’ and ‘temp_array’ commands (New in ChoiceScript: *create_array, *temp_array commands, *page_break_advertisement).

Changes

  • Upgrades ChoiceScript

This release is immediately available for the desktop versions of CSIDE via the ‘Latest’ or ‘Development’ update channels, and for the web version at ChoiceScript IDE.


Want to Help? You can contribute by…

Joining the Discussion on Discord

Trying Out Nightly Builds

https://choicescriptide.github.io/web/nightly

Raising Bugs or New Feature Requests

Either here or on Github.

9 Likes

Thanks for the update! Is there any way to get an option for the old vertical indents (on web specifically)?

I’m not sure I follow? The “nightly” builds will contain the upgraded text editor, so will have different (but immeasurably better) indent guides.

The production web version hasn’t had any changes on this front, so you should still be able to see the original guides as normal.

Huh. I assumed it was intentional but maybe not? They look like this for me:

image

I think the guidelines in the current version of CSIDE have always been horizontal?

Feel free to try out the nightly version(s) using the link above. That has proper guides (amongst a whole host of other improvements).

That’s strange, they’ve always been vertical for me. :thinking:

I’ll check it out, thanks!

1 Like

In fairness, if I’m being wholly honest, all of my free CS time goes towards developing the new versions of CSIDE. It’s been a very long time since I spent a lot of time in production CSIDE, so I’m very likely to get confused as to what’s current and what’s still in development… In short, you production users probably know more about that version than I do at this point :slight_smile: so I could be mistaken.

3 Likes

How do I update CSIDE to v1.3.3? I am using a mac and have accepted the "update to the latest version"n prompt from inside the desktop app, but it only updates it to v1.3.1.

You might need to be on the “Latest” update channel (in settings). Though I thought Stable was on the same now.

1 Like

I found it in the latest tab. Stable for mac is 1.3.1

1 Like

Keep getting the same error also. Any help, please?

I am also getting that same message. However i just got a new laptop with windows 11, the app on windows 10 works fine. I have freshly installed it in different spots after uninstalling it and removing it each time. I made sure it was installed as admin, tried running it in compat mode.

Just for testing i tried removing the app on windows 10 and reinstalling it and it did not give this error. Does CSIDE not currently work on W11?

This issue is related to certain hardware (caused by a bug in software, beyond my immediate control). That said, I haven’t tested CSIDE in Windows 11 myself (my current hardware setup isn’t compatible), so I’m very keen to hear from anyone using it and of any issues they might be encountering.

Late, but it works perfectly fine for me on Windows 11. I haven’t had any issues or anything from running it.

2 Likes

From what i can see, CSIDE lets me make and edit new projects just fine. It just throws that error on opening.

I can run both versions of the tests and even run the project. Is there any reason we should be wary of using CSIDE while it is throwing the error? Or do we simply not know yet?

1 Like