[CSIDE] The ChoiceScript IDE (v1.3.0 Now Available — 18/06/2019)

Okay thanks.

In the future I might modify CSIDE’s copies of the test to ignore (or just warn rather than error on) these commands.

2 Likes

Ok, brief background here: I’m about 1.5 million words deep in a WIP and have been using the Choicescript IDE since the beginning. Very recently, I got a new laptop and have been in the process of moving my files over from the old one. The IDE is freshly installed and seemed to run fine until I went to do a practice run of Chapter 1 to make sure everything was in working order.

Apparently, it isn’t.

The error I’m getting is:

My code looks like this:

*if choice_nightmode
        *gosub_scene csideimg_opening_quote_night
        *page_break
        *goto immediate
    
*if not(choice_nightmode)
        *gosub_scene csideimg_opening_quote_day
        *page_break
        *goto immediate

It’s been literally copy and pasted from the folder I’m using to move the files and is exactly as it has been since I first implemented it and previously worked fine.

My first solution was, “Okay, I’ll just add the variable in,” but of course, that gives me another error about how ‘choice_’ is a reserved command. So, no dice.

Is there a reason the program isn’t recognizing the command? Or have I missed a step between installing the IDE and the first startup file?

I’m not an expert on CSIDE, but the reason that it won’t let you add in choice_nightmode is that it’s one of the built-in variables that ChoiceScript uses, and it should always exist. The code should work - I created a test project with the following startup file and it worked fine.

*title CSIDETest
*author MuffiTuffiWuffi

*if choice_nightmode
        NIGHTMODE
        *finish
    
*if not(choice_nightmode)
        NOT NIGHTMODE
        *finish

If you make a new project and paste that code into the startup and it still fails it’s definitely something wrong with your install. I’m on v1.3.1 - you can see the info in the sidebar in the (?) button.

I can’t help with installtion issues but maybe you could try the CSIDE thread if that’s what’s going on? [CSIDE] The ChoiceScript IDE (v1.3.0 Now Available — 18/06/2019)

As @MuffiTuffiWuffi suggests, it sounds like you’ve not updated CSIDE to the latest version. Check the settings panel, it should be version 1.3.1.

Has anyone gotten this error before? I’m sure I have the latest ver of CSIDE so I’m unsure why I’m getting this. I think it’s looking for a file or two in the server?
Thanks in advance for the help :slight_smile:
Help

1 Like

I’ve sent you a PM :slight_smile:

Hi, I got exactly the same error message as LainyLu and would appreciate your help :slight_smile:

I use CSIDE regularly. I got my copy from the Github repository … today, when running RKill, Rkill flagged the IDE.exe file for malware processes and stopped it from running.

My other antivirus programs aren’t having an issue with CSIDE. Is this RKill flag anything to be concerned about? I would assume no, but I wanted to ask.

In doing more research, this seems it may be connected to the same issue LainyLu is experiencing. I am getting the same error and I wonder if the connection issue is somehow involved in the Windows process Rkill is flagging.

1 Like

As long as you’re downloading it from the official Github source, you should be good. But it always pays to be vigilant, so thank you for posting! CSIDE is built atop “NW.js” which is a wrapper application used across many apps (much like electron, if you’ve heard of that). Unfortunately, there have been malicious apps in the past that have used NW.js, and thus sometimes legitimate apps get flagged up as false positives. If you’re downloading CSIDE from a legitimate source (i.e. the only source: Releases · ChoicescriptIDE/main · GitHub), then you shouldn’t have anything to worry about. Though as aforementioned, it doesn’t hurt to be vigilant. Do look out for any change in behaviour or performance of your computer, and report it here.


The issue LainyLu was experiencing is unrelated. That’s a legitimate bug in the software that means some computers can’t download updates correctly. I hope to fix this with a major update some time this year. Until then I’ll PM you a workaround for that issue.

Hey there, just thought I’d put this here as it struck me as very odd. When I opened up the web version of ChoiceScript to work on it tonight, I noticed I had to open all of my files again in the program (not a big deal, just a big of information).

I then went to scroll down to the bottom of the page to start writing but it seems like the page caps how much you can scroll at once now? Like it will scroll a few lines, then stop, and I’ll have to wait a few seconds to do it again. Not only that, but when I click in the middle mouse button, it doesn’t do the drag scroll like it normally does, but just counts it as a regular left click. I tried it with my mousepad as well and got the same result. It’s also worth mentioning that it is the only tab on my chrome that does it.

Not sure if this is a bug or something on my end, although again, my scrolling seems to work fine on everything else on my computer.

How odd! There have been no updates in quite a long while, so if worked before and isn’t working now, I’d suspect it’s an issue on your end (though I can’t imagine what).

Any chance you could share a gif or video of exactly what you’re seeing?

There may be someone who wrote it before me, but have you ever thought of making the suggested droplist (showing possible variables or commands according to the piece of code written) while writing code to the IDE? Probably not very easy to write. But if you can add this feature, I think it would be great.

An example in case I didn’t fully explain the feature:

1 Like

Weird CSWeb scroll issue

So it may be hard to tell here, but essentially at first, I try to scroll full speed and it stops. Then I scroll very slowly, one tick at a time, and it scrolls no problem. I switch to a youtube tab and scroll full speed and it scrolls fine at full speed. Like you said, super weird.

Yes! The next version of CSIDE (release date TBD) should have this functionality.
I’ve started work on it, but there’s a lot to do yet.

You can see an example below:
Kapture 2022-06-19 at 23.31.38

There should also be support for scenes/labels, and parameter hints, as demonstrable with CSLIB:
Kapture 2022-06-19 at 23.37.30

You can try this out yourself (alongside other new features) at https://choicescriptide.github.io/web/nightly.


@ViIsBae

Agreed, it’s not easy for me to see what’s going on here. Thank you for providing that though, it’s a starting point at least. Do you notice any other patterns leading to the behaviour? Does it happen after using the app for so long, or only on certain (large?) files or projects perhaps? You may also want to try toggling some of the settings (do let me know if this fixes anything though, as that’s obviously still a bug!).

6 Likes

I don’t see any other patterns leading to it really. I just opened it up in my web browser one day because I use the web version to do all my writing/editing in (can’t forget to upload new versions to dropbox if you’re saving every update straight to dropbox) and the scrolling was wonky.

I will try it with my other project I have in the works and also try fiddling with some of the settings though! Weird thing is, it’s only the web version that does this, because CSIDE, the actual program, is totally fine.

1 Like

Worth trying another web browser too in that case?

Thank you so much. I’ve been wanting to write a story for a long time, but I’m a bit lazy. This will both reduce typing time and reduce possible bugs.

1 Like

I’m guessing that using this unreleased version for “production” rather simply testing would be bad idea?

The formatting colors alone is amazing thing.

Yeah, I wouldn’t recommend using that link for serious development. It’ll be representative of the latest development build, so highly likely to prove unstable at various points. But it’s useful for people to try out new features and give feedback.

What do you mean by formatting colours?