Compile is stuck on "Combining scene files" and won't finish

So all of the testing for my game worked completely, both quicktest and randomtest, and when I run it with index.html it runs fine. But when I try to compile the game into a finished form it just sits on “Combining scene files…” and never moves on to anything else. I’ve been waiting for at least half an hour now and I’m getting desperate. Full text:

Extracting js data from:

Extracting css data from:

Searching for scene files...

Game title set to: Infatuated Innsmouth

Combining scene files...

(I have other .txt files in the scenes folder than startup.txt and they aren’t showing up under the “searching for scene files” section either? I don’t understand what’s wrong)

I was trying to use this to finish a free demo of a concept for a game jam and it’s the middle of the night, it’s almost the deadline, I’ve finished the game and I just can’t upload it because I think I need to compile it to upload it? I’ve never actually completed a game before and I think that’s making it more stressful that the thing seems to be crashing on the final step like this.

I’ve been typing the code in Sublime Text 3–is that software part of the problem maybe? I really don’t know, it was testing fine.

Before anyone asks, I tried downloading the latest version directly from the site when it didn’t work. So unless the link is out of date I should have the most recent version.

1 Like

Do yoy have the capitalization correct on your scene files and scene list in startup.txt? That may be part of the problem

They’re all lowercase. Like I said, testing them works, it’s just compiling.

I’m not sure about the hanging, that could indeed be a bug, or a by-product of recent browser security changes. I’m afraid I don’t have a laptop with me to check today. However, you do need to fill out your *scene_list with all your scenes. This isn’t necessary for playing your game, but it is necessary to “tell” the compile script what scenes it needs to include. Please try this first.

If you’re still having trouble, you could try compiling using CSIDE. I’ll otherwise take a look when I’ve got a laptop to hand, assuming no one beats me to it. If you could zip up your scenes and send them my way via PM that’d also help.

P.S. you might be able to get us an error message from your browser via the console (F12).

1 Like

Going through CSIDE worked, and very quickly too. Was it something about going through the compile.html that was causing the problem?

1 Like

Glad to hear it! I couldn’t say without further investigation. As mentioned above, if you fancy sending me your scene files, I’ll do some digging once I have access to a computer.


Question resolved!