Can no longer play COGs on my Kindle Fire

Firstly I’m really confused as to what category this would go in, there’s not really a ‘Help me this COG won’t work’ one.

Basically, I’m not sure when it started, but for some reason I’m having problems playing COGs on my Kindle Fire 10 (7th gen).

Yesterday I tried starting a new one, this is how it went;

I got the first text box to type in my characters name, it typed in fine: Havoc.

Then on the next page I was asked to type in another name. I touch the text box so I can type in it, and the word suggestion (I think it’s called auto fill?) thing popped up, telling me I can put in Havoc again if I touch it. I ignore that and try to type in a new name, but nothing will type. The keyboard keys work fine when I touch it, I can capitalize and shift and change to numbers, it just won’t let me type in anything new as long as that auto suggestion is on the screen. I’ve only been able to recreate this in COG games. I’ve tried 15 different ones, (both Hosted and COG brand) same thing, can’t type on the second text box.

An odd thing I noticed; Usually no matter where I’m typing on my Kindle, the keyboard is set for the first letter I type to be capitalized. In this situation I noticed that on the second text box, it auto puts it to lowercase.

Things I’ve Tried:

Typing works fine on every other part of the device I’ve tried, Silk, the Search bar, the shopping apps.

I did a soft reset, where you hold the power button down until it turns off without you confirming. Didn’t fix it.

I went into the keyboard settings and turned off all the the auto complete and suggestions options, everything having to do with my device helping me finish words, didn’t change a thing, the auto fill still pops up and keeps me from typing. I think it’s a popup in the actual App, not my device?

I downloaded another keyboard and tried that, still nothing.

I did a factory reset, re-downloaded my apps (I did not restore a backup because I’ve always had trouble with that). Still the same problem.

I now have over 40 COG games that are unusable, and the only place they can be played are my Kindle because that’s where I bought em. I’m at a loss and ripping my hair out.

1 Like

Hi @AgentVerona,

The best place for support is the support email address: support@choiceofgames.com

2 Likes

This also happens on my kindle fire.

Having the exact same on my Kindle Fire HD 8 (7th gen). Tried all those fixes except the factory reset, no change. I emailed COG support two days ago, still haven’t heard back.

@JakWulf Sorry, looks like I missed answering a couple of recent emails about this - I believe I’ve just responded to yours.

More generally, we’ve gotten a few reports of this problem, but we haven’t been able to reproduce it in our testing, which makes it harder to figure out what’s causing it. If you’re having this issue, please do email us at support@choiceofgames.com, with as much information about your device and what’s happening with the text boxes as possible.

Just wondering if there’s been any progress with this issue. It apparently even affects the “Enter your name and email to save your game” function, if that helps.

For anyone having this issue: what operating system is your Kindle using? Is it updated to the latest available version?

Yes, all my stuff was updated to the newest firmware. It was really weird, I never touched any settings or anything. I guess it had just been a long while since I played a CoG or HG where I needed to type anything in, so I never noticed?

My situation was ‘solved’ by wonderful tech support who helped me transfer my purchases over to the Omnibus app on IOS, so I just read the games on there now, it works for me.

Hey folks, just wanted to thank you for working on this problem so diligently, and see if there’ve been any breakthroughs. Thanks!

Just wanted to say… Bug still here, but I found a way to outsmart it.
Copy some text, anything will do, and past it. Then delete it and write what you want.

It work for me. It’s not really ideal, but it work.

The delete part doesn’t seem to work with mine (only lets me type one letter after deleting copied text) however, it gladly accepts the copied text itself without issue! Thank you Lordlorac, this is fantastic! Not a perfect fix but close enough until there is one!