Bug Report for CS

@dfabulich I think you might have broken the gosub feature used in the stats screen in the latest version of CS. I keep getting caught in an endless loop again. Using FF.

I think the best way to contact Dan is actually via email.

Well I thought if others also had this problem they might want to see if it’s been fixed etc, so that’s why I chose to create a topic.

1 Like

Eh, I do my best to read threads where I’m mentioned.

@MutonElite, can you post a small snippet of code that reproduces the problem?

Uhm well it seems just to be a normal gosub_scene?

    *gosub_scene help
    *goto top

And within the help scene I only use *gotos and a return.

It worked fine on the last version I used.


I’m not sure if it’s the same problem you’re having, but I tried creating a codex as a separate scene accessed from the stats screen and it didn’t work. I had to create the codex within the stats itself (which is possible, but a bit of work) - the reasoning, I figure, why it happens, is because the stats will always jump you back to the previous point outside the stats screen that you were in when you entered it. I had gotten caught in an endless loop of not being able to get back to the game proper that way, too- but I did alter my coding to eliminate having an out-of-stats codex and it worked. Not sure if that will help you, but it might?

1 Like

Did you use goto_scene or gosub_scene? Because gosub_scene was fixed in earlier versions to be able to jump back and forth to the stats screen without overwriting the main game. In fact I made a post partially related to it;

I would have to agree that there’s something broken here. I’ve tested both the ability to gosub_scene and set variables in the stats scene, and they both worked as expected. Yesterday while testing out an idea I had, not only do variable changes not keep anymore, but I got stuck in a loop where it thought my stats page was the main game.

@dfabulich Any news on this issue, Dan?

I think this is fixed now in the latest version of ChoiceScript up on Github.


Yep, looks like it. Thanks a lot!

I notice that if I type in *image without a file name, example *image filename.jpg. It does not give any kind of error. It simply goes on as if nothing is wrong. I kept wondering why I was not seeing an image. Any other time if I give an incomplete command I get an error such as *set var it would stop the progress of the code as it does not know what to do with it. It took me some time to track down my error, is this something that may change, hopefully? I should add quicktest did not pick up on this as well.

1 Like

Thanks. Just passed this to Dan. It’ll be a bit for a it’s patched.